С чем связана ошибка kaspersky security center при установке на debian?
Всех приветствую!
Есть ВМ с установленным Debian 12.4, так же есть отдельный сервер с установленным PostgreSQL 13.7. При установке KSC 14 через данный скрипт - /opt/kaspersky/ksc64/lib/bin/setup/postinstall.pl
Получаю ошибку:
Administration Server registration FAILED. '#1963 Database connection is broken "`connection to server at "10.3.44.23", port 5432 failed: FATAL: no pg_hba.conf entry for host "10.3.76.12", user "dev-ksc ", database "postgres", SSL off
`, LastStatement=``" (D098D0BDD184D0BED180D0BCD0B0D186D0B8D18F20D0BED0B120D0BED188D0B8D0B1D0BAD0B53A20313936332F302028446174616261736520636F6E6E656374696F6E2069732062726F6B656E202260636F6E6E656374696F6E20746F20736572766572206174202231302E312E342E3237222C20706F72742035343332206661696C65643A20464154414C3A20206E6F2070675F6862612E636F6E6620656E74727920666F7220686F7374202231302E312E38352E3230222C207573657220226465762D6B73632E726F73656C746F72672E72755F6F776E6572222C2064617461626173652022706F737467726573222C2053534C206F66660A602C20204C61737453746174656D656E74>
Feb 20 02:20:37 vm01 kladminserver_srv[5481]: Служба 'kladminserver' остановлена из-за ошибки. #1198 Assertion "Administration Server registration FAILED. '#1963 Database connection is broken "`connection to server at "10.3.44.23", port 5432 failed: FATAL: no pg_hba.conf entry for host "10.3.76.12", user "dev-ksc ", database "postgres", SSL off
`, LastStatement=``"'" failed (D098D0BDD184D0BED180D0BCD0B0D186D0B8D18F20D0BED0B120D0BED188D0B8D0B1D0BAD0B53A20313139382F302028417373657274696F6E202241646D696E697374726174696F6E2053657276657220726567697374726174696F6E204641494C45442E2027233139363320446174616261736520636F6E6E656374696F6E2069732062726F6B656E202260636F6E6E656374696F6E20746F20736572766572206174202231302E312E342E3237222C20706F72742035343332206661696C65643A20464154414C3A20206E6F2070675F6862612E636F6E6620656E74727920666F7220686F7374202231302E312E38352E3230222C207573657220226465762D6B73632E726
При этом я могу подключиться к БД, через ВМ на которую ставиться KSC.
До этого делал всё на тестовой машине, всё работает, но на тестовой машине база была локальная.
Дополнительно:
no pg_hba.conf entry for host "10.3.76.12", user "dev-ksc ", database "postgres"
Если бы были проблемы с доступом я бы не смог подключиться к БД.
Но проблема возникает только, при установке KSC
Хотя по скрипту я ему указываю ранее созданную БД
В данном файле всё корректно настроено.
Точно в файле есть строка (с точностью до имени БД и метода аутентификации)
host postgres dev-ksc 10.3.76.12/32 md5
и она не маскируется никакой предыдущей строкой?
Я могу подключиться к БД с помощью - psql -h 10.3.76.12 -p 5432 -d ksc_db -U dev-ksc -W
И рут права есть.
Суть в том, что именно при установке он стучится на базу "posgres"
user "dev-ksc ", database "postgres"
host postgres dev-ksc 10.3.76.12/32 md5
Такой вид мне не подходит, так как системную таблицу postgres трогать нельзя.
Опишите проблему, и специалист поможет с настройкой, исправлением ошибки или доработкой сайта. Подберём понятный план работ без лишней переписки.
Пока нет других ответов. Будьте первым, кто поможет автору.
Ответить на вопрос
Ошибка Kaspersky Security Center при установке на Debian может быть вызвана несколькими причинами. Вот некоторые из наиболее распространенных проблем и способы их решения:
1. Несовместимость версий: Убедитесь, что вы устанавливаете совместимую версию Kaspersky Security Center с вашей версией Debian. Проверьте на официальном сайте Kaspersky список поддерживаемых операционных систем и их версий.
2. Недостаточные права доступа: Убедитесь, что у вас есть достаточные права доступа для установки программного обеспечения на Debian. Выполните установку от имени администратора.
3. Конфликты с другими программами: Проверьте, нет ли конфликтов с другими установленными программами или антивирусами на вашем сервере Debian. Возможно, необходимо удалить или отключить другие антивирусные программы перед установкой Kaspersky Security Center.
4. Неправильные настройки сети: Убедитесь, что настройки сети на Debian корректны и не блокируют доступ к серверам Kaspersky для загрузки необходимых файлов.
Если после проверки и исправления вышеперечисленных причин проблема с установкой Kaspersky Security Center на Debian все равно остается, рекомендуется обратиться в службу поддержки Kaspersky для получения дальнейшей помощи и консультации.